# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?=[^(]*\))/+/g;t' <<< "Lorem ipsum dolor sit amet, consetetur sadipscing (elitr, sed diam nonumy eirmod tempor invidunt, ut labore, et dolore magna aliquyam erat), (sed diam) voluptua. (At, vero) eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet."