# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r",(?=[^(]*\))"
test_str = "Lorem ipsum dolor sit amet, consetetur sadipscing (elitr, sed diam nonumy eirmod tempor invidunt, ut labore, et dolore magna aliquyam erat), (sed diam) voluptua. (At, vero) eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet."
subst = "+"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.