using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=[^(]*\))";
string substitution = @"+";
string input = @"Lorem ipsum dolor sit amet, consetetur sadipscing (elitr, sed diam nonumy eirmod tempor invidunt, ut labore, et dolore magna aliquyam erat), (sed diam) voluptua. (At, vero) eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}