# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^http:\\/\\/.*$)^.*?(\\/\\/.*$)//gm;t' <<< "http://google.com
// this is a single line comment
asdasd //asdasdasd adsdsa
"