const regex = /(?!^http:\/\/.*$)^.*?(\/\/.*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^http:\\\/\\\/.*$)^.*?(\\\/\\\/.*$)', 'gm')
const str = `http://google.com
// this is a single line comment
asdasd //asdasdasd adsdsa
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);