using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^http:\/\/.*$)^.*?(\/\/.*$)";
string substitution = @"";
string input = @"http://google.com
// this is a single line comment
asdasd //asdasdasd adsdsa
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}