$re = '/(?!^http:\/\/.*$)^.*?(\/\/.*$)/m';
$str = 'http://google.com
// this is a single line comment
asdasd //asdasdasd adsdsa
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;