import Foundation
let pattern = #"(?!^http:\/\/.*$)^.*?(\/\/.*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://google.com
// this is a single line comment
asdasd //asdasdasd adsdsa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)