#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(.addlicense)\s+(asf)?\s*((?<appid>(s/|a/)\d+)\s*,?\s*)+.*?(?<free>permanently\s+free)?"
Local $sString = " !addlicense asf a/431650,a/579730\nThis is most likely permanently free.\n\n^I'm&nbsp;a&nbsp;bot&nbsp;|&nbsp;[What&nbsp;is&nbsp;ASF](https://github.com/JustArchiNET/ArchiSteamFarm)&nbsp;|&nbsp;[Info](https://www.reddit.com/user/ASFinfo/comments/jmac24/)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")