const regex = new RegExp('(.addlicense)\\s+(asf)?\\s*((?<appid>(s/|a/)\\d+)\\s*,?\\s*)+.*?(?<free>permanently\\s+free)?', 'gim')
const str = ` !addlicense asf a/431650,a/579730\\nThis is most likely permanently free.\\n\\n^I'm&nbsp;a&nbsp;bot&nbsp;|&nbsp;[What&nbsp;is&nbsp;ASF](https://github.com/JustArchiNET/ArchiSteamFarm)&nbsp;|&nbsp;[Info](https://www.reddit.com/user/ASFinfo/comments/jmac24/)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}