re = /(.addlicense)\s+(asf)?\s*((?<appid>(s\/|a\/)\d+)\s*,?\s*)+.*?(?<free>permanently\s+free)?/im
str = ' !addlicense asf a/431650,a/579730\\nThis is most likely permanently free.\\n\\n^I\'m&nbsp;a&nbsp;bot&nbsp;|&nbsp;[What&nbsp;is&nbsp;ASF](https://github.com/JustArchiNET/ArchiSteamFarm)&nbsp;|&nbsp;[Info](https://www.reddit.com/user/ASFinfo/comments/jmac24/)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end