using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.addlicense)\s+(asf)?\s*((?<appid>(s/|a/)\d+)\s*,?\s*)+.*?(?<free>permanently\s+free)?";
string input = @" !addlicense asf a/431650,a/579730\nThis is most likely permanently free.\n\n^I'm&nbsp;a&nbsp;bot&nbsp;|&nbsp;[What&nbsp;is&nbsp;ASF](https://github.com/JustArchiNET/ArchiSteamFarm)&nbsp;|&nbsp;[Info](https://www.reddit.com/user/ASFinfo/comments/jmac24/)";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}