import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.addlicense)\\s+(asf)?\\s*((?<appid>(s/|a/)\\d+)\\s*,?\\s*)+.*?(?<free>permanently\\s+free)?";
final String string = " !addlicense asf a/431650,a/579730\\nThis is most likely permanently free.\\n\\n^I'm&nbsp;a&nbsp;bot&nbsp;|&nbsp;[What&nbsp;is&nbsp;ASF](https://github.com/JustArchiNET/ArchiSteamFarm)&nbsp;|&nbsp;[Info](https://www.reddit.com/user/ASFinfo/comments/jmac24/)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}