$re = '/(\w+):\/\/(\w+):(\d+)\?(.*$)/';
$str = 'GET://HOSTNAME1234:14159?arg0=C:\\sim.zip&arg1=C:\\bif.txt&arg2=C:\\wpt.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);