re = /(\w+):\/\/(\w+):(\d+)\?(.*$)/
str = 'GET://HOSTNAME1234:14159?arg0=C:\\sim.zip&arg1=C:\\bif.txt&arg2=C:\\wpt.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end