import re
regex = re.compile(r"(\w+):\/\/(\w+):(\d+)\?(.*$)")
test_str = "GET://HOSTNAME1234:14159?arg0=C:\\sim.zip&arg1=C:\\bif.txt&arg2=C:\\wpt.txt"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")