#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\6\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])\3\2\1|([A-Za-z])([A-Za-z])[A-Za-z]\2\1|([A-Za-z])([A-Za-z])\2\1|([A-Za-z])[A-Za-z]\1)\b"
Local $sString = "radar" & @CRLF & _
"racecar" & @CRLF & _
"cat" & @CRLF & _
"dog" & @CRLF & _
"reer" & @CRLF & _
"aibohphobia" & @CRLF & _
"mouse" & @CRLF & _
"house" & @CRLF & _
"louse" & @CRLF & _
"tattarrattat" & @CRLF & _
"supercalifragilisticexpialidocious"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")