import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\\6\\5\\4\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\\5\\4\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\\5\\4\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\\4\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\\4\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])\\3\\2\\1|([A-Za-z])([A-Za-z])[A-Za-z]\\2\\1|([A-Za-z])([A-Za-z])\\2\\1|([A-Za-z])[A-Za-z]\\1)\\b";
final String string = "radar\n"
+ "racecar\n"
+ "cat\n"
+ "dog\n"
+ "reer\n"
+ "aibohphobia\n"
+ "mouse\n"
+ "house\n"
+ "louse\n"
+ "tattarrattat\n"
+ "supercalifragilisticexpialidocious";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}