using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\6\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])\3\2\1|([A-Za-z])([A-Za-z])[A-Za-z]\2\1|([A-Za-z])([A-Za-z])\2\1|([A-Za-z])[A-Za-z]\1)\b";
string input = @"radar
racecar
cat
dog
reer
aibohphobia
mouse
house
louse
tattarrattat
supercalifragilisticexpialidocious";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}