const regex = /\b(?|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\6\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])\3\2\1|([A-Za-z])([A-Za-z])[A-Za-z]\2\1|([A-Za-z])([A-Za-z])\2\1|([A-Za-z])[A-Za-z]\1)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\\6\\5\\4\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\\5\\4\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\\5\\4\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\\4\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\\4\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\\3\\2\\1|([A-Za-z])([A-Za-z])([A-Za-z])\\3\\2\\1|([A-Za-z])([A-Za-z])[A-Za-z]\\2\\1|([A-Za-z])([A-Za-z])\\2\\1|([A-Za-z])[A-Za-z]\\1)\\b', 'g')
const str = `radar
racecar
cat
dog
reer
aibohphobia
mouse
house
louse
tattarrattat
supercalifragilisticexpialidocious`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}