#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(?:(p)).*tag-alvo.*?>(.*)<\/\1>"
Local $sString = "<div id='central'>" & @CRLF & _
"<p>O Primeiro conteudo</p>" & @CRLF & _
"<h1>O Primeiro n sei oq</h1>" & @CRLF & _
"<p class="tag-alvo">Batatinha quando nasce</p>" & @CRLF & _
"<p>Cabooo</p>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")