import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:(p)).*tag-alvo.*?>(.*)<\\/\\1>";
final String string = "<div id='central'>\n"
+ "<p>O Primeiro conteudo</p>\n"
+ "<h1>O Primeiro n sei oq</h1>\n"
+ "<p class=\"tag-alvo\">Batatinha quando nasce</p>\n"
+ "<p>Cabooo</p>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}