# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(?:(p)).*tag-alvo.*?>(.*)<\/\1>"
test_str = ("<div id='central'>\n"
"<p>O Primeiro conteudo</p>\n"
"<h1>O Primeiro n sei oq</h1>\n"
"<p class=\"tag-alvo\">Batatinha quando nasce</p>\n"
"<p>Cabooo</p>\n"
"</div>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.