re = /<(?:(p)).*tag-alvo.*?>(.*)<\/\1>/
str = '<div id=\'central\'>
<p>O Primeiro conteudo</p>
<h1>O Primeiro n sei oq</h1>
<p class="tag-alvo">Batatinha quando nasce</p>
<p>Cabooo</p>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end