const regex = /<(?:(p)).*tag-alvo.*?>(.*)<\/\1>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?:(p)).*tag-alvo.*?>(.*)<\\\/\\1>', 'g')
const str = `<div id='central'>
<p>O Primeiro conteudo</p>
<h1>O Primeiro n sei oq</h1>
<p class="tag-alvo">Batatinha quando nasce</p>
<p>Cabooo</p>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}