using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CrtDN:\s(.*?)\\r";
string input = @"CrtDN: CN=user1,OU=place1-sp,O=happy3,O=really\r\n\r\n>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}