import re
regex = re.compile(r"CrtDN:\s(.*?)\\r")
test_str = "CrtDN: CN=user1,OU=place1-sp,O=happy3,O=really\\r\\n\\r\\n>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")