const regex = /CrtDN:\s(.*?)\\r/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CrtDN:\\s(.*?)\\\\r', '')
const str = `CrtDN: CN=user1,OU=place1-sp,O=happy3,O=really\\r\\n\\r\\n>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}