// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"CrtDN:\s(.*?)\\r").unwrap();
let string = "CrtDN: CN=user1,OU=place1-sp,O=happy3,O=really\\r\\n\\r\\n>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}