re = /CrtDN:\s(.*?)\\r/
str = 'CrtDN: CN=user1,OU=place1-sp,O=happy3,O=really\\r\\n\\r\\n>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end