#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([^|]*)\|\d+\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$"
Local $sString = "ELINOR NORFUL DANDRIDGE|94608|832.81|CHEMTURA CORPORATION|10/8/2010 MI02 ‐ Royalties|11155987"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")