re = /^([^|]*)\|\d+\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$/
str = 'ELINOR NORFUL DANDRIDGE|94608|832.81|CHEMTURA CORPORATION|10/8/2010 MI02 ‐ Royalties|11155987'
# Print the match result
str.match(re) do |match|
puts match.to_s
end