const regex = /^([^|]*)\|\d+\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^|]*)\\|\\d+\\|?(\\d[^|]*)\\|([^|]*)\\|([^|]*)\\|([^|]*)$', '')
const str = `ELINOR NORFUL DANDRIDGE|94608|832.81|CHEMTURA CORPORATION|10/8/2010 MI02 ‐ Royalties|11155987`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}