using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^|]*)\|\d+\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$";
string input = @"ELINOR NORFUL DANDRIDGE|94608|832.81|CHEMTURA CORPORATION|10/8/2010 MI02 ‐ Royalties|11155987";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}