// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([^|]*)\|\d+\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$").unwrap();
let string = "ELINOR NORFUL DANDRIDGE|94608|832.81|CHEMTURA CORPORATION|10/8/2010 MI02 ‐ Royalties|11155987";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}