#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]{2}-[0-9]{2}-[a-zA-Z]{1,3}-[0-9]{4}$"
Local $sString = "DL-06-T-7405" & @CRLF & _
" (first two Alphabets then two Numbers then Alphabet and next four are Numbers) " & @CRLF & _
"or" & @CRLF & _
"DL-06-TT-7405" & @CRLF & _
"(first two Alphabets then two Numbers then two Alphabet and next four are Numbers) " & @CRLF & _
"or" & @CRLF & _
"DL-06-TTT-7405" & @CRLF & _
"(first two Alphabets then two Numbers then three Alphabet and next four are Numbers) "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")