import re
regex = re.compile(r"^[a-zA-Z]{2}-[0-9]{2}-[a-zA-Z]{1,3}-[0-9]{4}$", flags=re.MULTILINE)
test_str = ("DL-06-T-7405\n"
" (first two Alphabets then two Numbers then Alphabet and next four are Numbers) \n"
"or\n"
"DL-06-TT-7405\n"
"(first two Alphabets then two Numbers then two Alphabet and next four are Numbers) \n"
"or\n"
"DL-06-TTT-7405\n"
"(first two Alphabets then two Numbers then three Alphabet and next four are Numbers) ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")