$re = '/^[a-zA-Z]{2}-[0-9]{2}-[a-zA-Z]{1,3}-[0-9]{4}$/m';
$str = 'DL-06-T-7405
(first two Alphabets then two Numbers then Alphabet and next four are Numbers)
or
DL-06-TT-7405
(first two Alphabets then two Numbers then two Alphabet and next four are Numbers)
or
DL-06-TTT-7405
(first two Alphabets then two Numbers then three Alphabet and next four are Numbers) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);