const regex = /^[a-zA-Z]{2}-[0-9]{2}-[a-zA-Z]{1,3}-[0-9]{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]{2}-[0-9]{2}-[a-zA-Z]{1,3}-[0-9]{4}$', 'gm')
const str = `DL-06-T-7405
(first two Alphabets then two Numbers then Alphabet and next four are Numbers)
or
DL-06-TT-7405
(first two Alphabets then two Numbers then two Alphabet and next four are Numbers)
or
DL-06-TTT-7405
(first two Alphabets then two Numbers then three Alphabet and next four are Numbers) `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}