// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z]{2}-[0-9]{2}-[a-zA-Z]{1,3}-[0-9]{4}$").unwrap();
let string = "DL-06-T-7405
(first two Alphabets then two Numbers then Alphabet and next four are Numbers)
or
DL-06-TT-7405
(first two Alphabets then two Numbers then two Alphabet and next four are Numbers)
or
DL-06-TTT-7405
(first two Alphabets then two Numbers then three Alphabet and next four are Numbers) ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}