# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(?:-[^\.]*)(.*$)/$1$2/m;t' <<< "https://www.chemist.net/abbott-highestrated-hb-1200.html"