$re = '/(.*)(?:-[^\.]*)(.*$)/m';
$str = 'https://www.chemist.net/abbott-highestrated-hb-1200.html';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;