const regex = /(.*)(?:-[^\.]*)(.*$)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(?:-[^\\.]*)(.*$)', 'm')
const str = `https://www.chemist.net/abbott-highestrated-hb-1200.html`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);