re = /(.*)(?:-[^\.]*)(.*$)/m
str = 'https://www.chemist.net/abbott-highestrated-hb-1200.html'
subst = '$1$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result