use strict;
my $str = 'https://www.chemist.net/abbott-highestrated-hb-1200.html';
my $regex = qr/(.*)(?:-[^\.]*)(.*$)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";