const regex = /(?<=(?:d|folders)\/|id=)(?<id>[^\/?&\s]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(?:d|folders)\\\/|id=)(?<id>[^\\\/?&\\s]+)', 'g')
const str = `https://drive.google.com/file/d/1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG/view
https://drive.google.com/drive/u/0/folders/1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG
https://drive.google.com/id=1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG&type=`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}