import re
regex = re.compile(r"(?<=(?:d|folders)\/|id=)(?<id>[^\/?&\s]+)")
test_str = ("https://drive.google.com/file/d/1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG/view\n\n"
"https://drive.google.com/drive/u/0/folders/1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG\n\n"
"https://drive.google.com/id=1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG&type=")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")