import Foundation
let pattern = #"(?<=(?:d|folders)\/|id=)(?<id>[^\/?&\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://drive.google.com/file/d/1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG/view
https://drive.google.com/drive/u/0/folders/1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG
https://drive.google.com/id=1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG&type=
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)