re = /(?<=(?:d|folders)\/|id=)(?<id>[^\/?&\s]+)/
str = 'https://drive.google.com/file/d/1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG/view
https://drive.google.com/drive/u/0/folders/1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG
https://drive.google.com/id=1cq_DLarU2e6CKYwmL0eM2eN18c7bTquG&type='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end