#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)auth-worker.*?sql\((?P<user>\w+),(?P<ip>\d+(?:\.\d+){3}).*?(?:password mismatch|unknown user)\s*\(given password:\s*(?P=user)\)"
Local $sString = "Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(ryan,193.42.32.170): unknown user (given password: ryan)" & @CRLF & _
"Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(chris,193.42.32.170): unknown user (given password: ryan)" & @CRLF & _
"Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(chris,193.42.32.170): unknown user (given password: chris)" & @CRLF & _
"Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(user,193.42.32.170): Password mismatch (given password: user)" & @CRLF & _
"Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(admin,193.42.32.170): unknown user (given password: admin123)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")